시스코 라우터,스위치 경우에는 로그(LOG) 데이터를 콘솔 포트를 통하여 표시하거나, 라우터 내부 버퍼에 저장하여 필요할 때마다 엔드 유저가 보는 방식을 선택한다.
그러나 이 경우에는 시스템에 Critical한 장애가 발생하면 이용이 불가능하다. 따라서 로그 데이터를 라우터,스위치 내부가 아닌 외부 시스템에 저장하는 형태의 시스템을 제공한다.


대표적인 방법은 UNIX, LINUX 에서 제공하는 “syslod” 프로그램을 이용하는 것이다.

여기서는 LINUX를 사용할 것이다.

라우터의 표준 로깅 프로토콜이 LINUX의 데몬 프로그램에 자신의 로그 데이터를 전송한다. 그러면 이 로그 데이터는 LINUX 시스템의 특정 디렉토리에 저장하게 된다.

먼저 라우터의 설정을 보기로 하자.


RouterA#config terminal

RouterA(config)#service timestamps

RouterA(config)#logging x.x.x.x(ip주소)

RouterA(config)#logging facility local5



logging facility local5 이부분에 대해서는 개인적으로 알아보기 바란다

필자의 경우 local5로 설정했다.


이제 LINUX의 설정을 보기로 하자.


LINUX의 특정 파일 시스템 아래 있는 /etc/syslog.conf 파일을 수정하여야 한다.(root user로 로그인(login)해야 한다.) 이 파일의 마지막 라인에 가서

라인 추가를 하여 다음과 같이 작업한다.


local5.emerg            /var/log/cisco/log.emerg

local5.alert            /var/log/cisco/log.alert

local5.crit             /var/log/cisco/log.crit

local5.err              /var/log/cisco/log.err

local5.warning          /var/log/cisco/log.warning

local5.notice           /var/log/cisco/log.notice

local5.info             /var/log/cisco/log.info

local5.debug            /var/log/cisco/log.debug


이 내용을 저장한 다음 디렉토리와 해당 파일을 생성해야 한다.


필자의 경우 /var/log 에 생성할 것이다.


LINUX:/var/log# mkdir cisco

LINUX:/var/log# cd cisco

LINUX:/var/log# touch log.emerg logalert log.crit log.err log.waring log.notice log.info log.debug


Syslogd파일을 수정해줘야 한다


LINUX:/var/log# vi /etc/init.d/sysklogd


#! /bin/sh

# /etc/init.d/sysklogd: start the system log daemon.


PATH=/bin:/usr/bin:/sbin:/usr/sbin


pidfile=/var/run/syslogd.pid

binpath=/sbin/syslogd


test -x $binpath || exit 0


# Options for start/restart the daemons

#   For remote UDP logging use SYSLOGD="-r"

#

SYSLOGD="-r"


마지막으로 /etc/init.d/syslogd restart 한후

LINUX:/var/log# ps aux 명령어로 syslogd –r 을 확인한다.

root      9660  0.0  0.1   2540   900 ?        Ss   Jun04   6:58 /sbin/syslogd -r
 

신고



댓글을 달아 주세요

표준형 액세스 리스트는 deny, permit 의 단 두가지 동작만 작동된다.
 
설정 예 1) 1.표준형 액세스 리스트 정의
            
              #conf t
            (config)#access-list 1 deny 192.168.0.1 0.0.0.0                    ====> 표준형은 1부터~99까지
               (config)#access-list 1 permit 0.0.0.0 255.255.255.255           
            
              2.표준형 액세스 리스트 인터페이스에 적용
 
              #conf t
            (config)#interface fast 4/31
            (config-if)#ip access-group 1 out                                ======>스위치를 중심으로 in 은 들어오는 트래픽
                                                                                                                    out 은 스위치에서 나가는 트래픽
 
           
설정 예 2) 1.표준형 액세스 리스트 정의
            
              #conf t
            (config)#access-list 4 deny host 192.168.0.8                    
            (config)#access-list 4 permit any           
            
              2.표준형 액세스 리스트 인터페이스에 적용
 
               #conf t
            (config)#interface fast 4/29
            (config-if)#ip access-group 4                               
 
 
주의 : 액세스 리스트 정의 마지막에는 항상 permit any(=0.0.0.0 255.255.255.255) 을 넣어주어야한다.
         없을시 무조건 deny any(=0.0.0.0 255.255.255.255 )로 자동 지정되기 때문에 트래픽을 모조리 막아버린다.
신고



댓글을 달아 주세요

terminal length 0 라고 설정하면 됨.
default 값은 24 이며, 라우터를 리부팅하면 default 값으로 변경됨.


(참고) More 상태에서 역 슬래시(/)를 치면 단어를 입력할 수 있는데, 거기서 찾고자 하는 단어를 입력하면 바로 갈 수도 있습니다.. 예를 들어, /interface 라고 치면 interface로 시작되는 부분부터 다시 표시 됩니다.
신고



댓글을 달아 주세요

Cisco Catalyst 3500 시리즈 설정법  

HOSTNAME 입력
switch(config)# hostname <이름>

Telnet 접속용 VTY 설정
switch(config)# line vty 0 4

Telnet 패스워드 설정
switch(config-line)# password root

Enable 패스워드 설정
switch(config)# enable password

패스워드 암호화(Encryption 설정)
switch(config)# service password-encryption

스위치에 IP address 설정 (관리용 IP)
switch(config)# interface vlan 1
switch(config-if)# ip add <IP주소>

Default gateway 설정
switch(config)# ip default-gateway <주소>

Port group 설정
switch(config)# int fast0/1
switch(config-if)# port group 1
신고



댓글을 달아 주세요

[QoS(Quality of Service)]


▶ QoS 적용방법
1. Legacy CLI(Command Line Interface)


2. MQC(Modular QoS CLI)
  - 여러가지 QoS 기법을 적용할 수 있음(트래픽 절감, 지연이 적음)

ex) S1/0을 통과하는 http traffic은 3M bandwidth를 보장하시오
   a. 분류 : HTTP Traffic        => class-map
   b. 정책 : 3M bandwidth     => policy-map
   c. 적용 : S1/0 out              => service-policy
 

1) class-map
   - 속성 분류 (클래스는 대소문자 구별)
   - class-map match-all HTTP      => AND (default)
   - class-map match-any HTTP    => OR
   ex) HOST 10.1.1.1에서 발생하는 HTTP 트래픽에 대해서 3M bandwidth를 보장하시오
     # class-map match-all HTTP
       # match protocol http
       # match access-group 100                             => access-list 100에 해당하는 것들만 매치
         (# match any : 모두 포함해 매치)
         (# match not protocol http : http를 제외한 나머지만 매치)
     # access-list 100 permit tcp host 10.1.1.1 any
         ("match protocol http"항목 대신 access-list 맨 뒤에 "eq www / eq 80"을 넣어도 된다)


2) policy-map
   - 정책 구현 (클래스는 대소문자 구별)
   - 여러개의 클래스맵을 불러올 수 있다, 각각 적용 가능
     # class-map HTTP
       # match protocol http
     # class-map FTP
       # match protocol ftp
     # class-map TELNET
       # match protocol telnet

     # policy-map POLICY
       # class HTTP
         # bandwidth 3000
       # class FTP
         # bandwidth 2000
       # class TELNET
         # bandwidth 2000
       # class class-default


3) service-policy
   - 정책 적용
   - inbound / outbound 적용
     # int s1/0
       # service-policy [input | output] POLICY


▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒
Ex) MQC를 이용한 Classification & Marking
  a. 소스가 13.13.1.1/24, 목적지 192.168.3.1/24로 향하는 음성 트래픽(udp 16384 ~ 32767)
  b. 소스가 13.13.1.0/24, 목적지 192.168.2.1/24로 향하는 HTTP 트래픽
  c. 소스가 13.13.1.0/24, 목적지 3.3.3.3/24로 향하는 Telnet 트래픽


1) ACL 트래픽 정의 실시
  ip access-list extended VOICE
    permit udp host 13.13.1.1 host 192.168.3.1 range 16384 32767
  ip access-list extended HTTP
    permit tcp 13.13.1.0 0.0.0.255 host 192.168.2.1 eq www
  ip access-list extended TELNET
    permit tcp 13.13.1.0 0.0.0.255 host 3.3.3.3 eq telnet


2) 'class-map'으로 Classfication
  class-map VOICE_map
    match access-group name VOICE
  class-map HTTP_map
    match access-group name HTTP
  class-map TELNET_map
    match access-group name TELNET


3) 'policy-map'으로 Marking(QoS 정책) 실시
  policy-map INBOUND
   class VOICE_map
     set ip precedence 5
   class HTTP_map
     set ip precedence 3
   class TELNET_map
     set ip precedence 2

  interface ethernet 2/0
   service-policy input INBOUND
▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒


3. Cisco AutoQoS
  - 적절한 QoS를 자동으로 적용 (편리하고 빠름 / 최적화 QoS방법은 아님)
  - Cisco AutoQoS를 사용하기 위한 가이드라인
     => CEF enable / NBAR enable / interface에 bandwidth 설정
  - configuration
    # int f0/1
      # auto qos voip cisco-phone             => ip폰에 적절한 qos를 적용


4. Cisco SDM QoS wizard

  - SDM을 통한 QoS 적용 : 설정이 정해져 있어 유연한 적용이 힘듬



DiffServ QoS Model
  - 트래픽 타입을 근거로 로컬 장비에서 서비스
  - 출발지에서 목적지까지 QoS를 책임지지 않음
  - InterServe Model에 비해서 신뢰적이지 못함
  - 라우터 개별적으로 실시하기 때문에 확장성 및 규모가 큰 인터넷 환경에서 사용하면 효율적


  - QoS 처리 과정
   1) 트래픽 입력
   2) Classification(분류)
   3) Meter로 하여금 트래픽 측정 실시

   4) Marking(마킹) : 타 패킷과 구분하기 위함, 우선순위는 높을수록!
     - Layer 2 Frame (ISL, Dot1q) : CoS
         a. ethernet환경(PRI에 삽입) -> CoS(3bit) - 0~7(6,7은 사용x)
         b. frame-relay환경(DE에 삽입)
         c. MPLS환경(EXP에 삽입)

     - Layer 3 Packet
         a. IP Precedence(3bit | IP우선순위) - 0~7(6,7은 사용x)
         b. DSCP(6bit) 0~63    ==> PHB
            ex) # class-map test
                   # match access-group
                   # match cos 5                     => CoS 5 값(Voice)만 매치
                   # match ip precedence x
                   # match ip dscp y


     ※ DSCP(PHB) 가중치
          EF                                  = ip precedence 5   = CoS 5
          AF4(AF41, AF42, AF43)      = ip precedence 4   = CoS 4
          AF3(AF31, AF32, AF33)      = ip precedence 3   = CoS 3
          AF2(AF21, AF22, AF23)      = ip precedence 2   = CoS 2
          AF1(AF11, AF12, AF13)      = ip precedence 1   = CoS 1
          BE(default)                      = ip precedence 0   = CoS 0


         c. PHB(Per-Hop Behaviors | 3bit+3bit) : L2 - L3 호환
                 A    A    A   ||   B    B   |   0
             A. class : 001, 010, 011, 100=AF, 101=EF (숫자가 높을수록 우선순위 높음)
             B. Drop 우선순위 : 01=1(low), 10=2(medium), 11=3(high) (수치 높을수록 우선순위 높음)
            ex) AF31 marking 트래픽에게 3M 대역폭을 보장
               QoS 적용 라우터>>
                 # class-map PHB
                   # match ip dscp af31
                 # policy-map PHBPOLICY
                   # class PHB
                   # bandwidth 3000
               호스트 라우터>>
                 # class-map HTTP
                   # match protocol http
                 # policy-map HTTPPOLICY
                   # class HTTP
                   # set ip dscp af31


   5) Conditioner
     - Policing : 임계값 초과시 드랍 실시, 지연 없음
     - Shaping : 임계값 초과시 버퍼링 사용후 전송 실시, 지연 발생

   6) Congestion Avoidance(혼잡 회피)
     - Tail Drop : 디폴트 동작, 큐에 트래픽이 다 차면, 그 이후 트래픽들은 드랍
     - TCP Slow Start : 윈도우 싸이즈를 1씩 증가
     - RED : Random Early Detect
     - WRED : Weight Random Early Detect

   7) Queue 할당 및 스케줄링 실시(소프트웨어 큐 사용)
     - Queuing 스케줄러를 할당 받아 스케줄링 실시
     - FIFO 큐잉 : '머리 먼저 들어온놈 먼저 내보냄'
     - Priority 큐잉 : 클래스 별로 우선순위 할당, High, Medium, Normal, Low 구분
     - Custom 큐잉 : 16 개 클래스로 구분, 동등한 대역폭을 할당, Round-Robin 방식
     - WFQ(Weight Fair Queue) 큐잉 : '꼬리가 먼저 들어온놈 먼저 내보냄', 자동 동작
     - CBWFQ(Class-Based Weight Fair Queue) 큐잉 : 관리가 참여하여 실시, 'bandwidth' Command
     - LLQ(Low Latency Queue) : CBWFQ + PQ, Cisco 권장
     - IP RTP Prioritization : LLQ가 나오기 이전 음성트래픽에서 사용했던 스케줄러

   8) 시리얼리제이션 실시(하드웨어 큐 사용)
     - 패켓은 링크로 전송하기 위해 하드웨어 큐인 TX 큐(FIFO)로 전송

   9) 트래픽 출력

[출처] http://www.cyworld.com/nijoowplay/258033

신고



댓글을 달아 주세요

CISCO QOS

Network/Cisco 2008.06.25 20:18 |
QoS를 구현을 위해서 CISCO에서는 MQC라는 것을 사용하는데요..

간단히 정리하면 아래와 같습니다.

Class-map
Router(config)#class-map <match-all | match-any> class-map-name
Router(config-cmap)#[no] match <ip precedence | ip dscp | access-group>

Policy-map Class Action
Router(config)#policy-map policy-map-name
Router(config-pmap)#class class-name
Router(config-pmap-c)#[no] <police | set | trust>

Service-policy
Router(config)#interface interface-name
Router(config-if)#[no] service-policy input policy-map-name

간단히 Class-map는 어떤 패킷에 대한 정의를 하는 것이고 Policy-map에서는 적용한 것에 대한 어떤 행동을 할것인가...?? 끝으로 Service-policy에서는 인터페이스에 적용하는 이 3가지만 알고 있으면  QoS에 대해서는 어느정도 다했다고 생각하시면 됩니다. 물론 CISCO에서...
하나하나 설명드리면 가장 좋겠지만.. 다 설명드리려니 거의 책한권은 될것 같아서 가장 간단한 속도 제어하는 예제로 설명드리고 추가로 조금씩 설명드리겠습니다. 궁금한점은 "묻고답하고"에 글남겨 주시면 아마도 저희 카페 전문가분들이 답변해 주실것 같네요...^^

예제는 특정 네트워크에 대해서 10M 속도로 제공하는 것을 기준으로 예제를 작성하였습니다. 우선 모든 네트워크는 그냥 Permit 하고 192.1.1.0 네트워크는 10M로 속도 제어하려고 합니다. [참고로 CISCO 6509에서 실습한 예제입니다.]

1. 제일먼저 Access-list를 만들어야겠죠.

Router# configure terminal
Router(config)#access-list 2000 permit ip any any

Router(config)#access-list 2110 permit ip any 192.1.1.0 0.0.0.255 <- 10M 로 속도 제어하기위해서

Router# configure terminal
2. Router(config)# mls qos <-- PFC에서 QoS를 enable해야함.[필]
Router(config)# end

참고로 PFC[Policy Feature Card]에서 패킷분류, Policing 등의 QoS 기능을 수행합니다.


Class-map 작성
먼저 Class-map을 작성하는데요. 10M 과uplink_10M 이렇게 두개를  만들었습니다. 왜 두개를 만들었냐면 CISCO6509에서는 하나의 포트에서 input 패킷에 대해서만 속도제어가 가능하기 때문에 즉 가입자 입장에서는 up 속도만 제어가 되기 때문에 상위의 uplink 포트에서도 속도를 제어하면 down 스트림도 속도가 제어가능하겠죠. 아.. 어렵다고요... 저도 설명하기 힘드네요.. 그럼 그림으로 쉽게..


아래의 그림을 보시면 Backbone과 연결되어 있는 포트 들어오는 패킷에 대해서는 속도제어가 가능하지만 나가는 패킷에 대해서는 속도 제어가 가능하지 못하죠. 또 가입자 쪽으로 연결된 포트도 마찬가지로 들어오는 패킷은 속도제어가 가능한데 나가는 패킷은 불가능합니다. 당연히 Service 포트에서 input/output 포트 다 10M로 제한한다면 가장 좋겠지만 6509에서는 input 패킷에 대해서만 되기 때문에 어쩔수 없이 uplink포트에도 10M로 제한해야합니다. 참고로 input/output 모두 되는 기종은 GSR입니다.


class-map match-all 10M
  match access-group 2000

class-map match-all uplink_10M
  match access-group 2110

이렇게 두개를 만들었습니다. 이름은 아무것이나 주면 되는데 우선 가입자 10M로 그리고 uplink_10M는 업링크포트로 주도록 하겠습니다. 우선 Class-map에서 어떤 패킷인지 정의를 했습니다. 먼저 access-group 2000는 access-list 2000에 정의던 모든 ip에 대해서 trust 를 맞었고 192.1.1.0네트워크에 대해서 uplink_10M와 trust를 맞었습니다. 이거 말고도 cos,dscp 등 가입자에서 올라오는 패킷중 QoS를 목적으로 패킷에 마킹된 패킷에 대해서도 Trust해서 policy-map에서 처리할 수도 있습니다.


먼저 policy-map 이름을 uplink로 주고.
두번째 class는 위의 uplink_10M 에 정의 된 패킷이 들어오면 아래 Police를 실행하겠다는 의미 정도로 이해하시면 될것 같네요.
police 첫번째 숫자는 Rate [속도] 두번째/세배째 숫째는 Burst 끝으로 Action



policy-map uplink
class uplink_10M
    police 10000000 312500 312500 conform-action transmit exceed-action drop

policy-map 10M
  class 10M
    police 10000000 312500 312500 conform-action transmit exceed-action drop

이해가 가시는지요? 혹시 프로그램관련 해서 배운것 중에 if~ than ~else구문 아시죠?
if class=10M 이면 police 10000000 312500 312500 conform-action transmit 실행하고 else exceed-action drop
간단히 표현 하면 이렇습니다.

끝으로 서비스를 적용하는 구문  uplink포트에 policy-map uplink를 적용하고 가입자 포트에 10M를 적용하면 끝나죠. 참고로  Service-policy  다음엔 input /output이 있는데 조금전이 이야기한것 처럼 6500시리즈와 4000시리즈에서는 input만 됩니다. 그런데 가입자 포트는 모든 패킷에 대해서 10M인 반면에 업링크포트에서는 192.1.1.0 네트워크에 대해서만 10M인 이유는 업링크포트에는 192.1.1.0 네트워크 말고도 다른 네트워크가 지나갈수 있기 때문에 하나만 선택해서 Rate를 걸었습니다.

interface GigabitEthernet1/1
speed nonegotiate
service-policy input uplink


interface GigabitEthernet3/1
ip address 192.1.1.254 255.255.255.0
speed nonegotiate
service-policy input 10M

설명하다보니 상당히 길었는데요.. 이것말도 아직 무지하게 많습니다. 다 설명드리긴 조금 힘들고.. 다음시간에 간단한 것들에 대한 개념과 예제로 마칠까 합니다.

참고로 장비메뉴얼-cisco-"CISCO QoS 관련 설정 방법[MQC] 영문" 이것 보시면 조금이나마 이해하시는데 도움 될것 같습니다.

<출처 : http://cafe.naver.com/neteg.cafe >

신고



댓글을 달아 주세요

>> 스위치 기본 관리를 위한 설정...
- Console / Telnet / HTTP (WebConsole)
- SVI (Switch Virtual Interface) - vlan1

! Hostname 할당
Switch(config)#hostname DSW11

! enable secret 암호 설정
DSW11(config)#enable secret cisco

! Line Console 관리 설정
DSW11(config)#line console 0
DSW11(config-line)#logging synchronous
DSW11(config-line)#exec-timeout 0 0

! Switch에 관리를 위한 vlan 1 interface에 IP 할당하기
DSW11(config)#int vlan 1
DSW11(config-if)#ip address 192.168.1.100 255.255.255.0
DSW11(config-if)#no shutdown
 
! Switch에서 외부와 통신이 필요한 경우 Default-Gateway 할당하기
DSW11(config)#ip default-gateway 192.168.1.254
 
! Name 해석을 위한 NameService 구성
DSW11(config)#ip domain-lookup
DSW11(config)#ip domain-name bcmsn.com
DSW11(config)#ip name-server 168.126.63.1
DSW11(config)#ip name-server 168.126.63.2

! Hostname을 사용한 이름 해석
DSW11(config)#no ip domain-lookup
DSW11(config)#ip host DSW11 192.168.1.100

! Telnet 접속 관리
DSW11(config)#line vty 0 4
DSW11(config-line)#login local
DSW11(config)#username netsec10 password netsec10
DSW11(config)#line vty 0 4
DSW11(config-line)#password netsec10
DSW11(config-line)#login
 
! Telnet 접속 제한 (Access-list 활용)
DSW11(config)#access-list 10 permit 192.168.1.0 0.0.0.255
DSW11(config)#line vty 0 4
DSW11(config-line)#access-class 10 in
 
! Switch 초기화
DSW11#erase startup-config
DSW11#clear vtp counter
DSW11#delete vlan.dat
DSW11#reload
 
! Config.text  (NVRAM Emulation 파일)
! vlan.dat (Vlan Database를 저장함.)

! Vlan 생성
DSW11(config)#vlan 10
DSW11(config-vlan)#name sales
 
! Vlan 삭제
DSW11(config)#no vlan 10
 
! Switch Port를 VLAN에 매팽하기 (Access-list 만들기)
DSW11(config)#int fa0/10
DSW11(config-if)#switchport mode access
DSW11(config-if)#switchport access vlan 10
 
! Switch Range를 이용한 다중포트 설정
DSW11(config)#int range fa0/10 - 15 , fa0/18 - 20
DSW11(config-if-range)#switchport mode access
DSW11(config-if-range)#switchport access vlan 10
 
! Trunk Link 설정
** Trunk는 Public Server / Switch Uplink / InterVlan Router/....
DSW11(config)#int fa0/24
DSW11(config-if)#speed 100
DSW11(config-if)#duplex full
DSW11(config-if)#switchport trunk encapsulation {dot1q|isl}
DSW11(config-if)#switchport mode trunk
DSW11(config-if)#switchport trunk allowed vlan all
 
! Trunk Link 정보 확인하기
DSW11#show interface trunk

! Spanning-tree Protocol (802.1d header)
- Root Bridge ID  lowest Bridge ID를 갖는 스위치
- Bridge ID (Sender) 802.1d 를 전달하는 스위치
- Cost   IEEE에 정한 10G: 2 , 1G:4 , 100M:19, 10M:100
- Port ID   STP를 전달하는 Port Priority + MAC
- Hello Time  2 Sec
- Ford Delay   15 Sec
- Max Age  20 Sec
 
! Root Bridge 선출?  (Switch Default Priority 는 32768이다.16진수는 0x8000 )
 1. Priority (16bit) + VLAN_ID / MAC Address
     vlan1 에 MAC Address 0050.BF1C.83DA를 갖는 스위치는
     0x8001.0050.BF1C.83DA = 32769.0050.BF1C.83DA
** 선출된 Root Bridge는 매 2초 마다 STP Protocol (802.1d)를 전달한다.
 
! Port 선출?
1. Lowest Cost
2. Lowest Sender Bridge ID
3. Lowest Port ID
** Port ID? Port Priority (8bit) + Port Number
STP가 Fa0/24 번포트를 통해 전달 되어 질 때 Port ID는 0x80.24  (128.24)
 
! Spanning-tree 정보 확인하기
DSW11#show spanning-tree
 
! Root Bridge Priority 변경하기
dsw21(config)#spanning-tree Priority ?
  <0-65535>  Set a Spanning Tree Priority
 
! Root Bridge VLAN Priority 변경하기
dsw21(config)#spanning-tree vlan 1 Priority ?
  <0-65535>  Set a Spanning Tree Priority
 
! Switch Port Priority 변경하기
dsw21(config-if)#spanning-tree vlan 1 port-priority ?
  <0-255>  Change an interface's spanning tree priority
 
! WebConsole (Http 서비스를 이용한 GUI 관리 인터페이스)
! WebConsole 기본구성
DSW11(config)#ip http Server  ! Web Server enable 설정
DSW11(config)#ip http Port 80
DSW11(config)#ip http authentication enable
DSW11(config)#ip http access-class 10 in
DSW11(config)#access-list 10 permit 192.168.1.0 0.0.0.255
 
>> Switch Http 서비스 설정
dsw21(config)#ip http ?
  access-class     Restrict access by access-class
  authentication   Set http authentication method
  path             Set base path for HTML
  port             HTTP port
  server           Enable HTTP server

>> VTP (VLAN Trunk Protocol)
VTP Mode>>
 - Server ; flash:vlan.dat 파일에 내용을 추가/삭제/수정 할 수 있고, 변경된 VLAN
   정보를 flash에 vlan.dat에 저장하고, 같은 VTP Domin에 있는 다른 스위치
   에 Replicate을 한다. (기본 모드)
 - Client ; 같은 VTP Domain에 Server로 부터 vlan.dat 정보를 복제 받아 VLAN을
   운영하는 모드, 클라이언트는 VLAN 정보를 추가/삭제/수정할 수 없고,
   VTP Server로 부터 전달된 VTP-Summary를 다른 스위치에게 전달한다.
 - Transparent ; VTP Domain에서 독립된 VLAN Database를 유지하는 모드
           다른 스위치와 VTP Domain정보를 동기화 하지않는다. 하지만
           VTP-Summary를 받으면 다른 스위치에게 전달은 한다.
 
설정 단계?
1. VTP Domain을 구성한다. 같은 이름을 사용하는 스위치간 VALN정보를 동기화 한다.
DSW11(config)#vtp domain bcmsn1
 
2. VTP Option을 설정한다. (Password)  - 모든 스위치에 Password가 동일해야함.
DSW11(config)#vtp password 123456
 
3. VTP Mode를 변경한다. (Client 설정시에 먼저 VTP Counter를 초기화 후에 Reload하면
   다른 VTP Server로 부터 새 VLAN정보를 할당 받는다.
DSW11#clear vtp counter
DSW11#conf t
DSW11(config)#vtp mode client
DSW11(config)#end
DSW11#reload
 
>> VTP 상태 모니터링
DSW11#show vtp status
DSW11#show vlan brief
DSW11#show flash
신고



댓글을 달아 주세요

티스토리 툴바